Cabbage Logo
Back to Cabbage Site

Won't open after install

Cabbage seems to install on my Windows 7 machine, but it simply will not open. I immediately get the error message…

"Cabbage.exe - Entry Point Not Found

The procedure entry point csoundGetInputName could not be located in the dynamic link library csound64.dll."

Does anyone know how to fix this? I grabbed the latest CSound and installed it separately, but it made no difference.

Ji @DennysLot. This definitely looks like a version mismatch between Csound and Cabbage. When you run Csound from the command line what version does it report? Also, what version of Cabbage are you running?

Hey! Cabbage 2.5.0 and CSound 6.14.0. I think they’re both the latest, current releases.

Also, not sure how to run csound from the command line. Let me try and figure it out.

Okay, it says “Csound version 6.14 Feb 2 2020”.

I’m wondering if 2.5.0 uses a version of Csound that is not yet public domain. I now I added a new API call to it. Would you mind rolling back to version 2.4.0? If that works then I know where the issue lies with 2.5.0.

Will do. I’ll let you know what happens. :slight_smile:

1 Like

Not yet.

I uninstalled 2.5, installed 2.4 and it still gave me the error.

I rebooted, and reinstalled csound, and got the error.

Then I reinstalled 2.4 with the csound option for 6.15 checked and still got the error.

I don’t think it’s my antivirus or firewall, but I think I should mention that they’re running.

Some Windows 7 users reported this issue when they try to launch Cabbage from the installer. But when they tried again from the system menu it worked Ok? Can you try this?

Also, I had forgotten that Csound is now at release 6.15, I think 2.5.0 definitely needs this version of Csound…

I’ve been trying from the desktop icon, and I just tried from the Windows Start menu. Both not working.

I just tried CsoundQT and got the same error. Is that anything?

It looks there might be something up with your Csound install. Try uninstalling Csound from the system directory. Then install this version:
https://github.com/csound/csound/releases/download/6.15.0/csound-windows_x86_64-6.15.0-installer.exe
Then uninstall Cabbage. Reinstall either version you wish, but uncheck ‘install Csound’. Then close the installer and try launching Cabbage. I hope that works. Let me know.

I’m on it. :slight_smile:

1 Like

I just can’t make it happen.

Did exactly that, but it won’t start.

Uninstalled both, rebooted, then installed csound then Cabbage, same error.

I might have a Cabbage-made plugin already installed. Could that screw stuff up?

Okay, I got it running on my Win8.1 machine. So that’s something. At least I can use it. :slight_smile:

I’d still like to get it on my Win7 box, and since that’s where the Cabbage plugin is installed already, it’s becoming more and more suspicious. Like maybe the plugin already adjusted the Path files, and that’s screwing up the main program? Is that a thing that can happen?

Let me know what you think, and thank you for everything you’ve already done.

What Cabbage plugin are you referring to exactly? And did it work fine before you installed Cabbage?

I got “Granule” by Puremagnetik, and it was working fine. But I think it asked the same question about “add application directory to your PATH environment variable”, which is how I recognized it.

I say it WAS working fine, because just now when I started it up, it’s complaining that I don’t have python27.dll. Never did that before. Works fine once it loads, but it asks twice for python27.dll.

I just uninstalled both csound and Cabbage, and now it’s not asking for the dll anymore. Nutty.

(I just reached my max number of posts for a noob, and this is the only way I can respond. I’ll get back on here tomorrow. Thanks!)

Right, now we’re getting somewhere. So Granule ships with a csound64.dll. When it installs it adds the path to that dll to your system settings. If this path is before your path Cabbage will try to load that one, which is definitely an older version of Csound. However, if you remove that version Granule might stop working. The installers for later plugins don’t have this issue. If you reach out to @chronopolis (Micah) I’m sure he will send you an updated installer for Granule that will prevent any issues that might arise from an existing Csound install.

1 Like

@DennysLot I’ve changed that limit. I wasn’t even aware it was a thing. You should be able to post again now.

Rory! Hey! Got it to open up! I had to manually copy all the dll’s from Csound6_x64/bin PLUS python27.dll into my C/windows/system folder! Then everything works! :slight_smile:

…with the small exception of exporting a vst. :\

I started looking through the examples, really liked the String Feedback, exported it as a vst (and then as a vst3) but neither will open in Ableton 10.1. Just get a tiny little square that doesn’t make any sound.

Do I need to start a new thread, since my issue has changed? :wink: