Cabbage Logo
Back to Cabbage Site

Zlib1.dll error after press icon play on a csd loaded file


I’ve instaled Cabbage version: 2.5.0 and every time that a csd file is loaded and press play button,
bellow message box is displayed:


("Add to code respository: Cabbage.exe - Entry Point Not Found

The procedure entry point inflateValidate could not be located in the dynamic link library zlib1.dll")

If the loaded file is one of the examples, it works fine. However, if the loaded file is a very simple csd file like this (pad.csd from csound examples, but it’s the same with trapped.csd and xanadu.csd):

sr     = 44100
ksmps  = 300
nchnls = 1

instr  1
  kamp = 20000
  kcps = p4
  icps = 100
  ifn = 0
  imeth = 1

  a1 pluck kamp, kcps, icps, ifn, imeth
  out a1

instr 2
  kamp = 10000
  kcps = p4
  ifn = 1

  a1 oscil kamp, kcps, ifn
  out a1

#define BAR #2#
#define FOO #[$BAR + 1]#
f 1 0 16384 10 1
{ 3 $FOO
i 1 0 0.1 440
i 2 0 0.1 220
i 1 0 0.1 110
i 2 0 0.1 330



Cabbage doesn’t respond any more so I have to stop it .

Any idea on this please?

Many thanks.

Carlos Navarro

Can you try the latest beta version of Cabbage. I’ve seen this issue before in Csound, but I haven’t come across it with Cabbage.

Can you confirm that you are using Csound 6.15?

Hi Rory,

Thanks for your answer.

In csound directory, file say:


Version 6.14.0

I’ll install Cabbage beta version and let you know.


Can you also try installing the latest version of Csound? I think the problem might be that version of Csound. Thanks.

I did it: beta version and csound 6.15 installed but things still the same. I’m gonna restar my laptop just in case…If still not working, I will post some aditional data.


That’s very strange. I’ve no such issues on Windows. I assume you are using Windows 10? Can you try removing the image.dll from the Csound plugins folder? I know there was an issue with that at one point…


Removed image.dll and it seems solved the problem.

Many thanks again!


Yeah, it’s annoying when it happens. The image opcodes have a dependency on zlib. If it is not found we get that error. Anyhow, I’m happy that you got it sorted.