Cabbage Logo
Back to Cabbage Site

Audio file directory problems in the presets file

Hi everyone

I started using the Cabbage framework from version 2.3 to create plugins.
One of these plugins requires loading wav files which I have implemented in a working way.

The plug in provides for saving presets as the factory examples

In version 2.3 the presets worked fine for me and the files loaded with the file path saved correctly.

In subsequent versions of cabbage I found problems in the behavior of the presets that I was unable to resolve. It seems that when you save a preset the file path is saved with the addition of the path where the csd file is located.

This causes the file to fail to load when the preset is recalled.

Starting from the “DiskinFilePlayer.csd” patch present in the factory examples, I added the save presets with name function and called it “presets_DirectoryFileError”

This patch explains very clearly the problem I encountered. Just load any wav file into the patch and save the preset with a name then try to reload the preset again.
You can see the path of the file saved in the preset at the top left.

Thanks in advance, hoping someone can help me.

presets_DirectoryFileError.csd (13.5 KB)

Can you try the latest version? I just checked here and it works as expected. I can load files and recall them via presets. There was some changes made that busted the saving of files, but it should work fine now. Btw, 2.3 is a dinosaur, a lot of changed since then. :slight_smile:

Hi Rory

I had version 2.9 installed on my Mac and the problem was there.
In the latest version 2.9.132 you actually solved the problem.
A thousand thanks

I inform you that I exported the VST and loaded it into Reaper, it reads each file loaded from the various presets but unlike the version loaded from Cabbage, where if you select a preset, the name appears in the viewing window, inside Reaper when select a preset, it loads it for me but the name of the first preset in the list remains displayed.

I’ll send you a short video

Thank you so much Rory for not only fixing the problem
but for developing Cabbage (2.1 MB)

Can you PM me the .csd code so I can take a look?

I’ll send you the csd of the previous synth which has the same problem and the video of the Reaper and Ableton problemNew_Exemple Video (3.6 MB)

Thanks @tommig, this certainly looks off. I’ll take a look.

I’m still looking into this issue. This partly why I wrote the new presetbutton widget. These combobox / filebutton approach grew insanely and stupidly complex.

@tommig Can you try the latest build and let me know if this is resolved? It passes my test, but I’ll leave it to you to give it a proper test drive. :+1:

Hi Rory.
I have only now managed to test the new release with the bug fix.
I tried it and now the behavior is correct.

I thank you

1 Like