Cabbage Logo
Back to Cabbage Site

Cabbage Cannot Export APP/VST


I am trying to export my cabbage plugin as a standalone application and a vst but it is not working appropriately.
When I tried to export the app, the error pops up like this:

I also exported the vst to Library/Audio/Plug-Ins/VST but Ableton doesn’t recognize it:

I would really appreciate it if anyone could help me out so that I can use it to make music in Ableton :smiley:

Have a wonderful day!

What version of MacOS are you using?
What version of Cabbage are you using?

Hi Rory!

macOS is 11.1 Big Sur

Cabbage is 2.8.26

Download the latest beta package from here. Then enable the the perform adhoc setting:


Then try exporting again. If that doesn’t work you will need to codesign the binaries yourself. It’s not a great situation, but Apple is completely locking down software distribution and packaging on MacOS. Note that if you wish to share any plugins you will need to notarise them too.

Hmmm looks like it is still not permitted to install VST. The issue for exporting standalone remains the same.

Do you have any recommended methods to codesign the binaries? I haven’t heard of this term before.

Thanks a lot!

That error is usually because the plugin is in use in a DAW while you are trying to export it, or Cabbage simply doesn’t have the permissions to export to this location. Can you try a different location, perhaps one in your home folder?

Running the following on the binary file contained within the Contents/MacOS directory will do an adhoc code sign of your plugin, which should allow it to then be loaded by Live.

codesign -s - name_of_your_plgin_binary --timestamp --deep --force

If you get an error at this stage with somthing about resource forks, finder information, etc, you can run the following command:

xattr -cr name_of_your_plugin.vst

Sounds pretty straight forward. I just opened the binary file but it didn’t allow me to type any codes. The program cannot execute binary file :frowning:

Why would you try to open the binary file? All of the instructions above relate to the command line (terminal app on MacOS). If you’ve double-clicked something you’ve missed the point :grimacing:

Ohhh I thought that I needed to run the code inside the binary file…sorry that I misunderstood. I just run it correctly:

(base) Chenilles-MacBook-Pro:~ chenille$ codesign -s - /Library/Audio/Plug-Ins/VST/ChenLiuMarkovWave.vst/Contents/MacOS/ChenLiuMarkovWave --timestamp --deep --force

/Library/Audio/Plug-Ins/VST/ChenLiuMarkovWave.vst/Contents/MacOS/ChenLiuMarkovWave: replacing existing signature

Although I am still not seeing it show up in Ableton Live after rescanning and rebooting :(((

What version of Cabbage are you using?

Hi Rory,

I installed the latest beta you posted here two days ago. Right now it says 2.8.73

Arggh, I’m getting the same issue now. Disaster. Let me try with a local build and see if it’s the same…

Same issue with my local build. Darn it. Reaper opens the plugins just fine. Let me try some other things…

Yeah, something is certainly not right here. I have tried everything apart from notarising the plugin, and I still can’t get Live to open it. It has to be a combination of signing, and the fact that each Cabbage plugin needs to load Csound as a 3rd party library. I’m bust for the next day or two, but I am anxious to get this resolved too. I’ll let you know as soon as I have something to show.

Oh that’s too bad. No worries at all. Let me know if there is anything I can do to solve this problem together.

Will I be able to get rid of the security issues if I run everything in a virtual Windows machine?

I also found out that the VST is available in Logic Pro…
Hmm, something wrong with Ableton Live?

Hi Rory,

I just figured out that the plug-in appeared in Logic was actually an AU component I exported before. It is also available in Ableton Live inside the Puremagnetik folder. Looks like AU works perfectly fine so I guess there is something wrong with VST and VST3. Hope that it helps!

Are you on an M1 Mac? Logic comes with a utility that lets users run x86_64 plugins on arm64 architecture. In fact, it’s provided by the operating system as far as I know. This all means that people don’t have to worry about what architecture their plugin is when it’s an AU. VST/VST3 are different. And right now on MacOS we are stuck between two architectures and increasingly restrictive validation programs. It’s so bad that Apple won’t even allow developers to debug AUs in Logic. They insist that AU plugin developers first disable all security measures on their PCs and disconnect everything from the network. It drives me insane. Anyhow, I will try to get around to sorting this issue in the next few days. If I can…

I am using an Intel chip Mac from 2017.

Yeah, that’s terrible :((( More and more issues are coming out with Mac’s new system and chip, and I am worried if I should keep on working on a Mac or switch to a PC. I hope that it is still worth the time and effort for the community to struggle with Mac moving forward :worried:

Using AU solves my personal concern for now, but I will be in touch anytime to help out and keep the community and developers informed. Thanks a lot for your patience and support :blush:

Hi @chenliu52. I did some more work on this. It seems that my version of MacOS won’t let Cabbage plugins validate because they load a 3rd party library. I’ve tried all sorts of signing and entitlement settings, but just can’t get the right combination. So for this build:!Ah4mHoWvP_Gcg6d2s_J-WWxOlc-lyg?e=GgAjj2
I’ve linked Csound directly to the plugins, so Cabbage won’t technically be loading anything. It works Ok for me here, although I have to sign each plugin I export. Can you let me know how it goes? Thanks.