Cabbage Logo
Back to Cabbage Site

Cabbage not opening MacOS 13.4 even after codesigning via terminal

Hi everyone,
I’m running Cabbage 2.9.15 on macOS ventura 13.4 and I’m running into some issues even after running sudo codesign -s - --timestamp --deep --force.
It worked fine the first time I opened it, but after working on a project, saving, closing and then returning to it It seems it fails to launch.

I don’t get any error message particularly, but the Cabbage icon will just bounce on the dock and not open. After a while, running the Activity Monitor Cabbage will show as “not responding” and will stay there.

Anyone else dealing with anything similar? This is making it impossible to get any work done on my projects using cabbage :c

I didn’t think you would need to codesign the Cabbage app to run? I thought it was just plugins? But it’s hard for me to gauge as I can only test this on my dev machine, which isn’t exactly a typical end-user type setup.

Also, you should really be using the latest dev build. You can access them here:

I don’t think this is an issue with CodeSigning. I would imagine there is something else up. But try the latest build and let me know if it works better. There are improvements being made behind the scenes all the time. :+1:

Hi Rory, thanks for your response.
I dowloaded the latest dev build (2.9.153) and the issue still persists.

The app just hangs and becomes unresponsive, and I have to force quit and re-launch it multiple time times until it opens… sometimes it takes a couple of tries, some others it’s more like 10+ or so

Is there any chance you can record a short video/screencast of the problem for me! It might help identify the issue. I’m also on Ventura and have no such issues. What audio device are you using?

I’m really sorry it took me so long to get back to you.
Holiday’s and grad school really took a bunch of my time. I’m just using my external headphones as an audio device for this video. I’ve also tried it using my speakers & an external interface and it’s the same.

It’ll just bounce on the dock, until it shows as “not responding”. Couldn’t upload to forum, but here’s a drive link of a screen capture

No need to apologise. :slight_smile:

I’m stumped as to why this is happening. Are you using a silicon chip Mac? Or one with an older Intel chip? Also, can you try removing the Cabbage2.settings file from here:

Hopefully restarting after this will help. If not, we’ll keep searching for a solution. Btw, have you run Cabbage before without any issues?

Oh hang on, I just noticed that you’re code signing the Cabbage app itself. Do you really need to do this? It’s hard to for me to tell as my local machine is also my dev machine, but I thought you’d only need to codesign the plugins you export? Can you try removing from your applications folder and reinstall it, only don’t sign this time.