Cabbage Logo
Back to Cabbage Site

Cabbage not playing the code

Since I updated to Cabbage 2.7.0 I’ve been having this problem where Cabbage won’t show me the instrument’s UI when I press play and it also won’t get out of the play state when I press stop (I’m attaching a gif that illustrates that).

This never happened to me before 2.7.0 and I have no clue on what’s causing it. It’s also not entirely consistent, sometimes it will play the code fine, another it wont. Sometimes restarting my computer temporarily fixes the issue other times it doesn’t.

Any help is very much appreciated. I’m on MacOS 10.14.6 (Mojave)


Can you run Csound from the terminal and let me know what version you are running? There was an issue with one of the later versions of Csound that was causing problems with this. It was fixed in this release.

1 Like

I just updated Csound to the version you linked and the problem still persists

This is what the terminal is giving me now for version (and thanks for the reply):

For now can you remove the white spaces from your path. That should fix things until I get to the route of the problem…

Sorry, I’m not entirely sure what removing the white spaces from the path means exactly? Would that be removing all spaces from the installation path?

Sorry, it simple means remove any white spaces from any folder names you have. I see that the folder you are opening the file from has a space in it’s name. Actually, before you do that, can you try installing the latest beta build? Click this link, then click on the 3 dots that appears when you hover over the Drop link. They appear on the right hand side. Download the packages and install. If that doesn’t work, then try removing the white spaces. :+1:

The beta build didn’t fix the issue, actually. I removed the spaces from the .csd paths and it does work now, thank you so much.

Thanks for letting me know. This is a real tough one to track down as I can’t seem to recreate it locally. At least we have a fix for now, I will keep looking for a solution. :+1:

1 Like

Hi @Cippo, would you mind testing the latest beta build for MacOS and letting me know if this issue is now resolved? I’m also running the very latest Csound build from here. Before this build I was also experiencing issues with whitespaces, but this seems to have fixed it for me.

Hey @rorywalsh

I’m experiencing the same issue. The problem usually occurs if i write bugged code that doesn’t compile, and then remove the broken code. The problem persists across multiple projects if it happens to one. It happens randomly and affects projects i know have been working before. I don’t have any whitespaces in the path. Sometimes restarting my computer works, but not always.

Unless someone can produce the exact steps to reproduce the problem there is little I can do. I’ve tried so many times to recreate these conditions here but just can’t do it. 🤷

I can reproduce it by removing the headphones from the aux port. In older macos versions there was only one option, but now you can choose between external headphones and macbook air speakers, and the computer does this automatically when you remove the headphones. Maybe this has something to do with it…

So it’s something with the audio settings then? So I think when you change the audio settings like that you might break the patch which in turn causes no audio. Can you open the patcher window and observe what happens when you switch / unplug the headphones from the aux port?

When i unplugged, it created a node on audio input (probably because it automatically connects to the microphone along with the speaker) and connected it to the synth. Audio was playing successfully through the internal speakers. I then plugged the headphones back in and tried changing the output in cabbage settings back to headphones manually, but audio kept playing through the speakers. Therefore i had to restart the program, and when i tried pressing play the problem occurred.

And when you restart the program the audio connections are no longer made in the patcher?

No it never gets that far.

If you go to your Cabbage audio settings and re-select the audio devices then restart cabbage, does that help? I have a feeling that it won’t launch the instrument because cabbage doesn’t think the audio settings are valid :thinking:

No it doesn’t work :disappointed:

What happens if you try to load one of the examples that come with cabbage? Do they get added to the graph?