Cabbage Logo
Back to Cabbage Site

Can Cabbage send MIDI CC messages into a DAW's effect chain?

I am working on a plugin which controls other plugins in the effect chain of a DAW (in my case REAPER) by MIDI CC messages. (The intention is to create a complex pattern within a sound which is generated by a (non-cabbage) plugin.) I have previously written a plugin which sucessfully produces note-on (0x90) and note-off (0x80) messages using the csound opcode ‘midiout’, Now I tried the same to generate a CC (0xb0) but that does not work.

I wrote a small test example for this and attach it together with a REAPER file which includes JS MIDI Logger to show what happens. The test includes a couple of midiout commands which should create different kinds of note-on, note-off, CC, program change events repeatedly when the instrument is played. But in the log only note-on and note-off events appear.

Now I am stuck because I don’t have an idea what is the culprit. Although I post this here, I think it is least likely Cabbage. Could it be that something is wrong with csound’s midiout? I also don’t think this is likely. I am always insecure with the command line options of csound, especially ‘-Q0’. Finally, it could be that REAPER does not handle this properly. Maybe someone can check with another DAW?

MIDI-CC-problem,.zip (3.8 MB)

Ill check this tomorrow. Are you using vst3, or vst2.4? I think there might be some issues with CC messages in VST3, but I can’t say for sure. Hang on, let me check the MIDI out code…

[edit] I just looked, and it seems that the MIDI messages from Csound should be sent out the plugin’s MIDI output. :thinking:

Exported as VST2 the test file I sent you works. It sends all the eight MIDI commands into the MIDI logger at k-rate (which I reduced to 1/8000 not to overload the output). Whether it also works in the real environment, controlling another synth I will try later - getting too late tonight :wink:

Ok, then it seems that VST is the one with the problem. I think this is a known issue with VST3. But I can’t recall the details.

Thanks for telling me the VST3 issue. I would never have found out. Today, I also did the test with the real plugin I am working on. Unfortunately, for that REAPER ‘failed to scan’. (It shows up in the dreaded list you find under Options/Preferences/VST/Re-scan/Plugins that failed to scan…) Strange that the test file I sent you is scanned as VST2 but not the file which is scanned as VST3 (but then does not generate the CC). I will try to figure out the exact reason for this. But probably I really need a lot of time for this. Or do you know any ‘typical’ reason why Cabbage-generated VSTs fail to scan in REAPER?

Are you working on MacOS or windows?

Currently, I am only working on windows.

I’ve not had any issues scanning vsts, although I usually export VSTs rather than VST3s. Ok the other hand, one not had any reports from other Windows users about this. I wonder has it something to do with the plugin. Have you tried exporting one of the examples?