Cabbage Logo
Back to Cabbage Site

Compiling Lore

Hi guys,

Okay I’m new to this CSound and Cabbage business so I’m sure there’s something missing from my knowledge. Well, lots actually. I’m no stranger to code but it’s been a while and I’m wondering if anyone else is experiencing problems compiling Lore by Puremagnetik.

I’m compiling Lore and it kinda works. But in the Cabbage interface it doesn’t load the effects into the dropdown. They are in the includes folder. Okay fine it’s not looking at them for some reason, so I compiled it and exported it as a standalone. Now the includes are er included and the effects are showing . . . but it doesn’t connect to the audio output, it says it can’t open it. Doh.

This is revealing a fundamental issue for me: I don’t know how to point to includes when running it in the DE. And I can’t figure out why it’s not working as a standalone.

I appreciate that this is almost certainly a stupid question. Too many things that could be wrong, either with teh code or my understanding of it and for that I apologise in advance. Any suggestions gratefully received. Thank you.


Oh shoot I think it might be a bug . . .

Hi @philsouth, welcome to the forum :+1: I just merged the proposed fix. You can access the updated builds here, just press the three dots on the right of installers and get the zip file. Let us know if it works. :+1:

okay will do, thanks!

Okay I tried it. Hmm still not working. I get:

SeffectName = Cabbage
EffectPath = /includes/Effects/Cabbage.orc
WARNING: instr Cabbage not found
WARNING: compileorc: could not open /includes/Effects/Cabbage.orc

new alloc for instr 9:
WARNING: instr 9 uses 5 p-fields but is given 6
SeffectName = Cabbage
EffectPath = /includes/Effects/Cabbage.orc
WARNING: instr Cabbage not found
WARNING: compileorc: could not open /includes/Effects/Cabbage.orc

It’s still not opening the includes for some reason.

What am I doing wrong? If I compile it as a standalone it’s no longer showing the effects (same as running it in Cabbage) and the audio devices are turned off (to avoid feedback loops apparently)

Boy this is harder than I thought.

Maybe we should ping @chronopolis here, considering he wrote Lore :slightly_smiling_face:

1 Like

I mean it’s working, in the sense you can get sounds into it and manipulate them, but none of the effects are online. Also the Font is wrong, I think so it’s not loading that either, As with any software or code, if one thing isn’t working I suspect other things might not be. :slight_smile: Trouble is I can’t tell if it’s a Cabbage problem, a Lore problem or a Me problem. Too many variables man!

For what it’s worth, Effects and includes are tested and working in my latest development version of Cabbage - what I built the official distro with. I will look today or tomorrow if something changed that precludes it’s functioning properly. It is a version from July or so and might be obsolete now.

Thank you! I’m loving it so far, or at least the bits I can get to work. Like I say it’s hard for me at my end to know what’s casuing the anomalies, Cabbage, Lore or my own brain. I can’t guarantee the latter but your help with either of the former will be delightful. :slight_smile:

1 Like

I won’t have a chance to look into it today. This sounds like something changed with how Cabbage deals with strings or file extensions in the combobox or on init.

I’m on Cabbage 2.8.114 and that’s what the official distros were built with… if anyone wants to investigate what could have changed. Otherwise, I can hopefully look into it tomorrow.

Hmm I’m on 2.8.154 now . . . maybe I need to retrograde it . . .
Thanks for your help, really appreciate you taking the time.

Oh except I don’t know how to get that specific 2.8.114 beta. Any clues @rorywalsh ?

That was an old beta, it won’t be available any more. I can build it for you, but I’d rather get to the root of the issue first. See here for updates.

yeah I’m right with you there, best get to the bottom of it. I can wait, I’m old and patient. :slight_smile:

1 Like

Confirmed on Cabbage 2.8.154

EffectPath = includes/Effects/.orc

The “effect name”.orc isn’t loaded. Digging in now…

1 Like

I have to run out for the day and do Dad things :slight_smile:
But we can start here… I should have time tomorrow to look more into it unless an intrepid soul wishes to figure it out :laughing:

form caption("EffectsTest") size(300, 200), colour(0,0,0), guiMode("queue"), pluginId("2084"), openGL(1), opcodeDir("."), bundle("./includes"), typeface("includes/Inconsolata-Regular.ttf")
combobox bounds(10, 0, 100, 20), channel("EffectList1"), channelType("string"), value("Empty") $EFFECTLIST
-n -d -+rtmidi=NULL -M0 --midi-key-cps=4 --midi-velocity-amp=5 --displays
; Initialize the global variables.
ksmps = 16
nchnls = 2
0dbfs = 1
seed 0

gSEffectDir = "includes/Effects/"

instr 1
    cabbageSet "EffectList1", sprintf("populate(\"*.orc\", \"%s\")", gSEffectDir)

i1 0 500000
1 Like

I’d like to say intrepid is my middle name. I’d like to. :slight_smile:
I’ll watch this space.

Meanwhile on the Lore GitHub tracker, things are progressing…