Cabbage Logo
Back to Cabbage Site

Compiling Lore

what where how? wha’happen?

Ohhh okay I see it

:joy: Yeah, I think we may have identified the change that caused things to break. Watch this space…

1 Like


Yes, I’ve narrowed it down to the combobox for sure.

Yep that’s what my comboboxes look like. Empty. Like my soul. :slight_smile:

Can you try the latest build from here. The problem seems to have come about by a change I made to stop Cabbage plugins from setting the current working directory when they open. It’s not good practice, but the change seems to have caused some issues. @TartanLlama has updated the source. Hopefully it will work now. :+1:

thank you so much for doing this, I’ll have a look right now

hmm it loads the drop down for effects but what is the white box next to it, shouldn’t that be an icon?

Also when selecting the items from the dropdown you get error messages below

sorry I’m really good at breaking stuff

The white box should be a .png file
Looks like something might have changed in the way cabbage deals with the string that references that file.

Edit : Actually, based on your screenshot it looks like the entire .orc file isn’t loading as the controls are blank too.I will try to investigate tomorrow. It is likely something with how the .orc file location is parsed.

That box has always been white, for me.

Something else occurs to me. I’ve been switching back and forth between versions a lot. I have tended to install over rather than uninstall and re-install. Old habit/bit lazy. Should I clear it all out and do a fresh install? Is that something which causes problems?

yes, it’s back to the fact that Cabbage ‘used’ to set the current file path as the current directory. That is no longer the case. I’ll fix this.

1 Like

Look forward to it, thank you.

Oh did I also mention I sometimes get a loud humming sound which doesn’t go away until I reboot? I think it crops up sometimes when I run Lore. I can probably figure out the pitch if that helps. Not sure I’m helping at all :frowning: Sounds like mains hum but higher.

Of course this might just be a vaguery of my system. I realise there are many variables.

Did you try the new build? Does it work? Here is the link.

I tried the last one you posted, but I’ll give that a go.

Thanks the most recent link is for a build done yesterday :+1:

1 Like

Oh and another fly in the ointment is I keep getting Avast One telling me the file is suspicious and then labourisously scanning it and then telling me it’s fine. It’s very annoying.

Nope, same thing.

No effects.

Is it me? Is my setup breaking something. Maybe the virus checker is nobbling it?