Cabbage Logo
Back to Cabbage Site

Entry Point Not Found

Clipboard01

I installed v2.3.0. on a Windows 10 Machine. Although all seems to be installed and paths set the program fails with “The procedure entry point csoundGetInputName could not be located in the dynamic link library C:\Program Files\Cabbage\Cabbage.exe”

  • tried run as Admin
  • tried Reinstall
  • tried installing QTcsound

Hi @Thomas. It looks like you may need to update your Csound version? Can you try the latest from here:

Thank you, but this did not alter the error on launch.

Can you try the beta windows pacakges from here. When installing, disable installing of Csound, so that Cabbage uses the version you already have installed on your machine. Let me know if that helps.

Not sure if related, but I have similar popup error when trying to run (pressing play button) built-in examples from the menu or basically any project. All of them give the attached error: The procedure entry point inflateValidate could not located in the dynamic link library etc.

The popup appears twice in a row and then examples seem to work OK though.

Using version 2.5 on windows 10. Just installed recently for the first time on a new machine, downloaded C-sound during the cabbage installation with a corresponding tick.

Hi @emir.more Can you try installing the latest version of Csound from here:


No need to uninstall or reinstall Cabbage, simply install this version of Csound to the standard location and see if that helps. Looks like the install of Csound while installing Cabbage might not be correct.

Just Installed from csound-windows_x86_64-6.15.0-installer.exe - still having the popup

That’s odd. Do you have any Csound based plugins installed on your system? You don’t happen to have ToneZ installed anywhere?

Nope, it’s a relatively fresh machine. Only have reaper installed with no extra plugins and VB-audio virtual cable. But don’t think these may cause the issue.

The problem is with the image opcode in Csound. It’s trying to find a library that is not there. I thought updating Csound might fix it. The best thing would be to remove image.dll from the plugins64 directory. That should fix the issue, although you won’t have access to the image opcodes…

Are there any crucial parts in those image opcodes?

Only if you want to do some kind of image analysis. To be honest, if I ever wanted to generate some audio based on images I would use a proper image analysis toolkit and send the results to Csound rather than using these opcodes.

Oh, OK, that’s actually an interesting topic to explore, but right now I wanted to learn some physical modeling basics, renaming image.dll - fixed it. Thanks!

Looking a bit ahead, would it be possible to connect some external image analysis toolkit to cabbage and output it as VST?

It would be tricky, but possible if you were able to write your own opcodes for that purpose. Or lese you could pipe the image analysis data to Cabbage via OSC. I would just load Csound in a Javascript or Python and then use an image analysis toolkit in that language to send data to Csound.

Cool! Thanks for the insights.

Hi again,
I actually have installed ToneZ plugins yesterday and today I cannot start Cabbage anymore. The error is

error-2.5.12

Excuse my German :wink:, but I guess it is the same message as what this thread is concerned with but with ‘csoundLoadPlugins’ instead of ‘csoundGetInputName’.

From your post I guess there is a problem between Cabbage and ToneZ although (or because) both are based on Cabbage/CSound. Will it help to de-install ToneZ? (I fear it is not just deleting ToneZ.dll but maybe also some registry stuff.) Or better would be a way to avoid this error keeping it because ToneZ is really a great plugin!

PS: I am running Win 10 Pro, Cabbage 2.5.12 (stable 2.5.0 throws the same error), Csound 6.15.0

Can you rename the csound64.dll that’s comes with ToneZ? I think it might be lobster in the ToneZ program data folder…

Thanks for the fast response. I did not find a csound64.dll in the ToneZ directory. But your hint led me to solve the problem. I have reinstalled csound over the existing installation. That seems to reset the changes done by the ToneZ installation. And fortunately the ToneZ plugins still work in Reaper.

Great. I think ToneZ comes with its an earlier version of Csound. So installing it over a newer version might lead to some issues. Anyhow, glad to hear you got it working :+1

Hi emir.more. I have the same issue

Cabbage Error

This happens in any Cabbage project. How did you fix it?