Cabbage Logo
Back to Cabbage Site

Exported VST crashes Reaper

I exported the ‘Physical Modelling/BassGuitar.csd’ as a VST 3 instrument.
I Noted several oddities:
The name of the csd does not appear in the folder where it is exported to:
2 files appear there: ‘Physical Modelling.csd’ and ‘Physical’, but that is in fact the folder name. (Maybe I should have changed it when exporting)
In Reaper it is shown as: CabbageEffectNam (CabbageAudio), this does not look right. And when I try to add it to my track, Reaper exits…

I’m not sure VST3s work on Linux. Can you try a standard VST export? The names of the files are exactly what you set them to be when you exported them.

No, VST also crashes. And in Reaper the name is always “CabbageEffectNam (CabbageAudio)”. Where does this come from?

Yup, I just tested here and I’m seeing the same issue. I’m not sure why, leave it with me. This is a new development…

Btw, and you building from the dev or master branch?

I do not know, my foldername is cabbage-2.4.0

Ok. I have spotted the issue. Thanks for bringing it to my attention. We don’t have many Linux users at the moment. Can you try the latest dev source?
Just use the same build steps as before. I’ve tested this here with my Linux machine and Reaper, and it’s all good :wink:

It still crashes here. BTW, it complained about jack/jack.h not found, so I had to do this first: sudo apt-get install libjack-dev
The name in Reaper is still the same…

More trouble: the install of libjack-dev removed my qjackctl, so I installed it again, but now Jack cannot start anymore

Working fine for me here. I just checked again. What version number does Cabbage show in the about menu…?

That is 2.4.7. BTW, could it hurt if Reaper is set to use Jack and Cabbage exported the VST when it uses ALSA?

I’ve got the same issue currently with all VST on Linux, I don’t know if it’s exactly the same bug but VSt3 and VST2.4s cause Reaper to completely crash out, same thing happens in all DAWs I’ve tried - Ardour, Waveform9, Carla etc. I managed to get a crash report saying it was caused by a segfault in the csound plugin, can’t find where it’s stored at the moment.

I do remember during the latest build there was an error - I think when linking - in csound loading plugins. I ignored it and it seemed to work. I could reproduce it if you want…

Cheers, it could help

Here’s the output:
Linking CabbageLite - App
Copying over docs and icons…
/tmp/cc91MOdO.o: In function Csound::LoadPlugins(char const*)': testCsoundFile.cpp:(.text._ZN6Csound11LoadPluginsEPKc[_ZN6Csound11LoadPluginsEPKc]+0x23): undefined reference to csoundLoadPlugins’
/tmp/cc91MOdO.o: In function Csound::GetInputName()': testCsoundFile.cpp:(.text._ZN6Csound12GetInputNameEv[_ZN6Csound12GetInputNameEv]+0x18): undefined reference to csoundGetInputName’
collect2: error: ld returned 1 exit status

This is the first I’m hearing about this. I can’t reproduce the problems here @AMadFool, can you let me know what distro you’re using? VST3 might not work, it’s completely untested.

@zappfinger, that error has nothing to do with Cabbage, but a utility that Cabbage uses if it’s available. It should have no bearing on the running of Cabbage. The problem is in linking an application called testCabbageFile. You’re right to ignore it.

Cabbage plugins are interface agnostic. They are entirely in the hands of the host applications, so this wouldn’t make any difference.

Btw, are you guy building with JUCE 5.4.7? You should do, and not the latest master branch, which is currently 6.1. Please try building again with JUCE 5.4.7.

I will update the readme now to reflect this…

Btw @zappfinger, Mint is basically based on Ubuntu right? If I prepared binaries for you here on my Ubuntu box, would they run for you? Sorry, I’m not so deep into Linux these days…

Btw @zappfinger, Mint is basically based on Ubuntu right? If I prepared binaries for you here on my Ubuntu box, would they run for you?
Yes, Mint is based on Ubuntu, so I guess binaries should run on Mint…

Yeah I’m on Juce 6.0.1. I’ll try the older version and see what transpires. Thx :slight_smile:

This is where it goes ‘wrong’ for me with Linux as a whole. Things for the end user should either be all on Github or via the developer website but not both. Developers build shiny websites to attract new users but then it turns out everything on the website is the wrong version and doesn’t work and you should download from Github. It’s the same with Cabbage - there’s a big shiny website there with a download button. If you’ve googled something that’s the one you’re going to download. Nope wrong version. This is reason number one that people shy away from Linux imo. It’s 2020 and people still cant get JACK to work half the time. I digress. :slight_smile: :slight_smile:
I’ll report back how I get on. I assume I’ll need to recompile Cabbage as well as Projucer? I will do anyway, no harm in it.

I agree with you entirely but I need help here. You mention all plugins crash for you, but as far as I am aware you didn’t bring that up until this thread appeared? I will work on preparing an installable .deb package. That would at least be a step in the right direction. I would love Cabbage users to be able to apt-get install Cabbage, but I have no idea how to achieve this. I really do need help from the Linux community on this.

Hi Rory
No I didn’t bring it up until this thread appeared. I only got Cabbage installed and working last week if you remember. I’ve not looked at it much since too busy with the day job and the part time job of actually being a music producer. I tried a VST export etc for the first time at the weekend. I also tried the Windows version in a VM - plugins out of that work, natch also tried them via LinVST etc. to see the potential in that but they don’t work probably because of the wrong Csound file in that instance but people wouldn’t need to do that if native Linux does the business anyway.

Can you try this package? Extract, and then run the install script.

sudo ./installCabbage

I just tested here with a fresh VM image (with Csound installed) and it worked Ok. I didn’t have time to test exported plugins as I have classes to run to. Don’t worry if you don’t have time to test. I will try later anyhow.