Cabbage Logo
Back to Cabbage Site

Exporting FMOD effect plugin has undesired behaviour

Hey, I was making an effect plugin for FMOD in cabbage, but I have an issue I can not figure out.

I am using the ins opcode (I have tried inch as well with the same result) to get the audio from my mic, and presumably the FMOD sound when the event is played.

When in cabbage, when I hit play and talk in my mic, the output sounds totally normal.

When I export the plugin to FMOD, it almost sounds like it is highpassed, or weirdly distorted (I am an audio noob, so I don’t know the right terms)

Here is my super basic csound code:

Here is a video of the FMOD audio playing (its supposed to be the taco bell sound):

Any idea why this is happening and what I can do about it? Thanks!

That’s odd. Can you try changing your ksmps value? See if increasing it (stick with power of 2 sizes) helps. It’s a while since I did any work on this, but I believe there are still a few people using it without issue. Actually, i might ping @Deinol and see if he can offer any help. Btw, what version of Cabbage are you using?

Changing the ksmps value did nothing. I tried all the way up to 4096.

I am using a beta version that I downloaded from your azure DevOps link. I do not remember exactly which one. With the normal 2.6.0, I did not get the option to export FMOD plugins within cabbage. Could this be the problem that I am using an unofficial release?

No, it’s always best to use the latest builds. What build of FMOD are you using?


Hey. Thanks for the ping Rory!
I’m not sure if I’ll be able to provide any help (I don’t really have time to dig a lot into it) but we’ll try.

Could you, @ThijmenBos try to set up the effect plugin using a parameter to control it and see if it is plugin’s fault or fmod messing something up?

Hey. I did that before, and it seems to be on fmod’s side. However, I found the default fmod effects are enough for what I need, so I won’t need any more help. Thanks for the response you two!

1 Like

Thanks for letting us know. And thanks @Deinol for your input. :slight_smile: FWIW, I tired the effect interface yesterday and couldn’t get it to work. I have to go back and learn how to use FMOD again, it must be a decade since I last looked at it!

1 Like