Cabbage Logo
Back to Cabbage Site

Help Missing MSVCP140D.dll & libwinpthread-1.dll cannot running cabbage on win 7 32

Help Missing MSVCP140D.dll & libwinpthread-1.dll cannot running cabbage on win 7 32

What version of Cabbage are you using? Which package did you use to install it?

Hi Rory, thanks for respon, I’m using cabbage v1.1.0 for 32 bit Windows 7.

Can you try this one:

If that doesn’t work for you I will update the installer to include those files. Sorry for the inconvenience.

still same rory, error massage.

I’ve attached two zips here that you can place in your Cabbage directory. Let me know if that works. (21.9 KB) (201.4 KB)

Hi Rory, thanks for your respons,

I try manually attach all missing dll files, as the error message pop up,

and then this error message pop :
the procedure entry point _vcrt_cleanup_type_info_names could not be locate in the dynamic link library VCRUNTIME140D.dll

Windows 7 Pro 32 bit

I’m stumped on this one. I can run the 32bit version here without any issues, but that’s on a 64bit OS. I wonder is something else messing it it up. Do you have Pd installed? That uses some similar dlls, maybe there is a conflict somewhere?

Hey Rory,

I landed on the same problem. I downloaded Cabbage 32-bit from the latest Beta package linked above.

I was trying to target plugins for Windows 32bit users. So I have a Windows 7 32-bit fresh install running on VMWare. But the VSTs compiled as dll’s in my 64bit Cabbage in my host was not getting recognized at all by the 32-bit DAW on my guest operating system. So I figured I would have to recompile them in Cabbage 32 bit. So I installed 32-bit Cabbage on the virtual machine and I got the same dependency errors as @diannebula. But once I fixed those, more and more dependencies kept cropping up, and I went on a goose chase with the following DLLs:


and I stopped at this point of time and thought there must be something fundamentally wrong. :stuck_out_tongue:
So I was wondering why the VST dll’s were not getting recognized by the DAW in the first place?

That’s really odd. I can try rebuilding the 32bit version, but that process is becoming more and more labour intensive now that Csound is only being released as 64bit.

Oh, alright. So how would you suggest I handle VST’s for a 32bit OS ?

Good question. My 32bit dlls have always worked on 32bit hosts running on a 64bit Windows. I’ve never tried them on a native 32bit OS. Nor do I have the option of trying. This certainly looks like a linking issue. I’ll rebuild and see if I can fix it. Leave it with me.

As according to me ; you dll file is missing .So i am providing a link you have to download msvcp140d.Then i am sure your problem can be solved without any conflicts.