Cabbage Logo
Back to Cabbage Site

No waveform display

Hi guys,

For some reason, I can’t get any waveforms to be displayed in soundfiler for any of the examples (e.g. Grain3FilePlayer, DiskinFilePlayer). The waveform display just shows “(No audio file loaded)” after I select a file in the open file dialog. What’s interesting is that csound seems to play the files back just fine and all the instruments are working without a hitch. Just not seeing any waveforms.

I’ve tried multiple files, all .wav. No dice.

I’m on Cabbage 2.0.03 on macos 10.12.6.


Thanks Alex. I’ll take a look.

[edit] Works Ok for me here on Windows. I’ll try OSX a little later. Can you confirm that a valid audio device is selected before you try opening the file?

That’s correct. The audio device is selected before I open the file and synthesis works just fine.

I have to do some work on OSX tomorrow. I’ll try to take a look at this then too.

DiskinFilePlayer works and shows file here on OS 10.13.6 and Cabbage v.2.03. I would doubt that it was the MacOS?..

Thanks Iain. I’ll check tomorrow and see if I can recreate the problem. @Alex what happens if you close and reopen the plugin window without recompiling the instrument? It might be some strange painting issue?

Hey Rory,

That actually worked! If I close the window after I open a file, then reopen the window, the waveform appears.

Another data point: I just tried all of this on a different computer (also macos Sierra), and I get the same behavior there – no waveform unless I reopen the plugin window. Also, strangely it all works in Cabbage Studio…

Good that we now know where the problem is. Have you tried this as a plugin too? I suspect it might work fine there. For all of the problems users face when developing instruments in Cabbage, the exported plugins are usually rock solid.

I can’t recreate this issue here on my OSX machine. I’ve a few new updates in the pipeline so hopefully they will make a difference to this, even if I can’t recreate the problems.

I think I’ve seen something similar a few times recently, but with the gentable widget. The common thread for me seems to be when loading 32bit IR waves, but it hasn’t happened enough for me to really be sure. Might be unrelated, but I’ll keep an eye on it’s behavior and maybe run a few tests when I can.

edit: actually, I just looked… it was the soundfiler widget.

Hi @t_grey, you’ve been keeping quite! :wink: Can you provide an example?

I have! I took a while off from almost everything csound related, and I’m hoping coming back in fresh will give me some new ideas and perspective on issues that I was stuck on before.

I haven’t tested very extensively yet, but most (probably all) of the samples from the Samplecity “Bricast” collection found here: seem to load, but not trigger an update on the soundfiler widget making it appear to not have loaded. I tried both in my instruments, and in the diskin player example.

Here’s a specific file for testing that triggers this behavior:

So loading this with a soundfiler example doesn’t work? Sorry, I’m not sure how exactly I can recreate the problem if I don’t have an instrument to test with…

I tested with “Examples | FilePlayers | DiskinFilePlayer”, using Cabbage2 64 2.0.02 (Apr 30 2018)
edit: ^OSX

It opens the file, but the waveform isn’t displayed as if it didn’t load. Pressing keys makes the appropriate noise.

Does this not happen for you?

Ok, this is weird. Using the file unzipped straight out of the archive creates the bad behavior. The version of the wave I uploaded and now redownloaded does NOT create this behavior.

Even weirder… they both report the same md5 checksum.

:thinking: Not sure how to proceed here :joy:

I get the same issue on windows 10. I’m using an older update on it, but I only get the waveform if I close and open the window.

I agree, this is a bizarre problem.

I’m not sure, but this (at least for me) seems likely to be a directory location or permissions based issue. I had unzipped the archive into a shared folder where all of my samples are kept, but the downloaded sample I had provided was in my home directory. When I copy the shared location file to the home directory, it starts loading properly again.

I’m going to play with this some more later and see if I can narrow it down to an exact reason, it may not be cabbage’s fault… but if it is it’s probably an extremely rare set of circumstances. I have no idea if other people’s problems fall into the same category, or if that was just a similar red herring.

So that was also using the official release, but it does work with using one of the recent builds on a machine with the latest win 10 updates.

Thanks @Slappz, that interesting to note. @t_grey , can you try the most recent OSX build?
It’s still a little behind the current dev snapshot as I’m having CI issues. I’m currently in the process of moving everything to a different CI system. So I hope to have automated builds for OSX again shortly.