Cabbage Logo
Back to Cabbage Site

Reaper not exporting sound for tracks with Cabbage plugin effect


I made a simple convolution plugin effect with pconvolve and using the button widget to get the path for an audio file to serve as the impulse and whenever I try to render a track that uses this plugin in Reaper, the particular track affected by the plugin is just silent.

I tested the same plugin in Cubase and it exports alright. I also have no problem exporting audio from two other synths I’m building with Cabbage in Reaper, just this one convolution effect.

I can freeze the track in Reaper and the plugin prints fine, I just can’t render an export with the plugin working. Does anyone know why might that be?

Thanks in advance!

Can you confirm that the problems occurs with the Cabbage convolution example? If so I have something to test with. Alternatively, can you post your .csd file so I can test with that?

Just tried it out with the McCurdy’s Convolution Reverb Example and the problem still occurs in Reaper.

Here’s my .csd:
Convulera_Stereo_v1.csd (4.3 KB)

Edit: also after exporting, the plugins acts like there isn’t an impulse response loaded, muting all audio coming from the affected track (but still shows the loaded waveform on the display)

Thanks, I’ll check it out when I get a moment. Most likely tomorrow evening :wink:

I’ve been using the plugin more and I’ve been noticing some inconsistent behaviour with regards to file loading. When reopening a session, some instances of the plugin seem to “remember” the file I loaded previously while other instances start blank. I noticed this on both Cubase and Reaper.

I’m sorry I haven’t had a chance to look into this yet. I’ll definitely have more time towards the second half of the week. Watch this space…

No worries at all! Take your time

I’m just trying this out here, and it seems to work fine for me. I can load an impulse. Tweak the parameters, and then render to disk. The resulting audio file is what I hear when I process the sounds in Reaper.

I’m using 2.5.0.

I’m going to check the sessions saving issue now :+1:

[edit] my impulse responses are also saving with the session. I wonder is there anything unique to how you are saving them or recalling them. I thought for a moment it might have to do with the plugin editor window being closed when saving is taking place, but I tested that too, and it still loaded Ok. :thinking:

Sorry for the delay, now it’s me who hasn’t had a chance to look into this lately.

I’m using Cabbage 2.3.0 actually, will try updating and see if that fixes it!
With regards to saving I don’t think I’m doing anything unique (just command+s to save the session and opening it back again by double clicking the session file)

Ok, try the latest and let me know. If you really want the latest bleeding edge versions grab one from here:
Each successful build will have a ‘published’ artefact that will contain platform installers. If you can reproduce your problem with one of these latest builds we know the problem is still prevalent. :+1:

Installed Cabbage 2.5.0, re-exported my plugin as a vst and got this error on Reaper (Cubase also can’t load the plugin). I also tried exporting the example convolution reverb as a vst but it doesn’t even show up in Reaper

Can you try downloading the installer from this Drop link and let me know if it works any better?


Hi, sorry for the delay again.

Just updated my Cabbage to 2.5.5 from that link. The problems are still persisting - Reaper still doesn’t export tracks with the convolution plugin (unless frozen) and both Cubase and Reaper don’t always remember the loaded convolution files when reopening a project.

I can’t recreate the problems here. What OS are you using?

MacOS 10.14.6

I’ll test myself tomorrow and see if I can recreate it. I was testing up till now on Windows.

Sorry for the delay in testing this, but I still can’t recreate the problems you’re seeing. The impulse files all load fine for me after I save the session in Reaper.

I can also render the tracks from Reaper without any issue. They rendered track is processed as I would expect. Is there something I’m missing here? I believe I am carrying out the same steps as you?

Hmm, yes, those seem to be all the same steps indeed. I also just updated my Reaper version just to be sure but the problem is still there. Is there any other information from my setup that could be helpful in determining what’s going wrong?

I’m using a slightly older version of OSX, but apart from that I can’t think what else might be different. :thinking: I can prepare you a special build that will write the plugin session data to disk as a text file perhaps. At least this way we will see what it’s actually saving. I will run one off tomorrow for you.

Awesome, thank you!