Cabbage Logo
Back to Cabbage Site

Single line groupbox issue?

Hello Rory, I’ve been away a while and am trying to get caught back up. I downloaded the newest standalone beta for OSX from: Latest beta packages available here (updated links)

First, I ran into a small problem with groupboxes that are on a single line, for example an exmpty box like this:
groupbox bounds(10, 218, 360, 190), colour(55,55,55,55), fontcolour(50, 50, 50, 255) { }

It seems as tho the groupbox never sees the terminating bracket. If I move the second bracket to a new line everything seems to be back to normal…

Second, I have some horrible buffering issues… it seems to be more prevalent in some instruments than others, but that might just be my imagination. Buffer and samplerate are same between both versions ( and 2.0.20a). Csound from console reports 6.08. Aside from that, it frequently crashes if I save a .csd file, or sometimes even just when I close. Any suggestions?


Good to have you back :wink: First question, why are you using curly brackets at all in this instance? They are only used for plants.

Do you have a few examples we can try out? I just tried several of the instruments that ship with Cabbage and they seem to run fine for me.

Everything is more or less the same on that front between the two different versions. The GUI underwent a pretty extensive rewrite, but the audio guts of the software remains more or less the same. Keep in mind however that I’m using the latest version of JUCE. But I don’t see how that could be an issue.

I don’t suppose you can consistently create the crash? That really would be helpful, but I understand that these things just kind of happen at times. To be honest, I experience a lot less crashes with this version that the older one. But I still seem to be able to crash it from time to time. I’m pretty sure the crashes that take place are due to some kind of weird memory problems whenever Csound gets destroyed and re-instantiated. Can you try installing the latest version of Csound 6.09 and see if that helps at all? You can install it to the defaul location. Cabbage will find it.

Oops! Those got there because this is a background box that shows when the plant with controls is made invisible. I guess the braces can be deleted too! Either way, it wasn’t an issue with the older version of cabbage… but I’ll fix the improper usage on my end as well. :wink:

That’s what I was understanding too, which is why I was surprised to have issues. I’ll admit, some of these are pretty extensive in the UI silliness, so I’ll try simplifying some examples to see if I can isolate my issues. I also had noticed that the first few examples I tried were working fine. After a minute or two, it almost seems like’s it’s only an issue with mic input, and only on certain instruments? I’ll check my csd options in the instruments too, I might have some old cruft that needs to get cleaned out.

I’ll see if I can get it happening regularly… in my first session with C2 it seemed to be very regular, I’ll probably have another go with it tonight. It was mostly when closing an instrument text file (especially if the gui was still up), it would cause a hang.

I’m still seeing some issues on my end… the buffering audio type of issue is specific to Cabbage2 (both versions of csound), and a new cabbage GUI related problem that affects both versions of cabbage, but only in csound 6.09 that I’d love some input on, if you can find a little time.

Crashes in C2 seem to come mostly when closing a csound file, sometimes when closing C2 with multiple files open, but never really consistently. Doesn’t seem specific to having any one file, but I’ve also mostly only tested with my own projects so far… so it might be something specific to what I’m doing.

Mind if I strip down a few and send it to you off list as a tar.gz or zip? I’m working on a bunch of effects and instruments using common include files and test audio.

If you tell me I’m crazy after looking at it, I won’t argue :innocent:

Sure, you can PM me the files. If you weren’t crazy you wouldn’t be using Cabbage in the first place :joy: