Cabbage Logo
Back to Cabbage Site

Ui go bye bye

So i updated cabbage to 2.3.49 from 2.3.0, and dudes stole my UI. Cant have crap in detroit

edit: Ive taken a look at the code quite a few times, there are no unended brackets, or out of position widgets. Nothing makes sense

edit 2: removing the update instrument from the CsScore makes everything reappear, but then all the tabs and stuff are broken. Is this more of a cabbage slug?

It’s a strange one. Can you PM me the full project?

Thanks for sending me the files. In this case I think the problem is in the path you provide for the images, i.e,

image bounds(0, 0, 308, 308) file("Skin/Default/LFO 2.png")

If you wish to use back slashes, you need to use two of them together, otherwise the parser thinks it’s an escape sequence.

Simplest would be to use forward slashes:

image bounds(0, 0, 308, 308) file("Skin/Default/LFO 2.png")

After I made these changes it works fine. Not that traditionally, forward slashes were Mac only, but Windows has supported them for a quite some time too. So if you just use forward slashes your paths should be platform agnostic.

Hmm, that doesnt seem to work. i feel like the problem lies in the update instrument code, but i have no idea where. it just broke after i updated cabbage. When i fire it up can see the gui for a split second then it disappears. Taking the “i “UPDATEGUI” 0 3600” out of the CsScore shows the gui. But its not just the pictures that are missing. The knobs, comboboxes, sliders, all of it. I have a hunch that somehow it got behind the groupboxes somehow :thinking: because i have a background image and that still shows up, so i dont think its the image path…

edit: when did text in the nsliders become so big? because the text looks like its overflowing the y of the nslider sssss

I just checked with the latest build on Windows and it works fine?

You can set the size of the number text. You can use fontsize(). More info here

Sorry, been away from the pc for a while. What? thats wierd. Whenever i fire it up the gui just… dissapears.

do you have discord? maybe we can screenshare,

Can you show me your current audio settings? If no card is selected the instrument won’t run, which could be giving issues…


Let me go back to Windows for a sec…

I tried just now on a second Windows machine and it also worked fine. Just so we are on the same page, can you try the latest beta build here

OK, i downloaded the latest beta, and this thing is still broken.

I assume you are on Windows 10?

yes. Windows 10 version 1903

Right, let’s see if we can find where the problem is. What I would do is comment out all of UPDATEGUI and then start ucommenting lines out till you find the offending one…

Alright. I have the entire instrumwent commented. Im gonna comment out all the kTrig variables first bc i dont think thats the issue…

edit: uncommented trigger variables, not the issue

:laughing: I like the live updates!

Ok, so i un-commented the oscillator tab code, and that has caused the oscillators to dissapear. Its like the very existence of this code makes it dissapear…

just to be clear, this is the same code from before i updated cabbage and it worked fine before

I believe you, but I just can’t think what might be causing the issue. See this line here:

groupbox bounds(636, 4, 308, 308) visible(1) identchannel("GROUP_OSC34") plant("GUI_OSC34"){
    groupbox bounds(0, 0, 308, 308) visible(1) identchannel("GROUP_OSC3"){

You have an ident channel that is never used. Can you remove it and try again? Perhaps there is a parsing issue…

Ok. Right now I’m out and about. I’ll see if that does anything when I get home

Let me know.It might be tomorrow before I can return to this. I guess our time zones are a little out of sync…

Ok. Im back. It doesnt seem that (“GROUP_OSC34”) is doing anything, but removing it also doesnt do anything

edit: the plant isnt the issue either