Cabbage Logo
Back to Cabbage Site

VST on Mac

Hi,

I am having problems exporting VST synth on an Intel MacBook running Sonoma 14.4.1, Cabbage 2.9.0 installed using installer.

Even if the plugin exports just fine, it is not recognisable (at least not by Audition or Audacity which I have locally). Audacity pops a message about plugin being incompatible Audition just ignores the plugin (a black screen pops up when it is scanning it occasionally though) .

This is irrespective of whether I export as VST, VST3, or AU.
The same behaviour emerges both when I export my own patches or the examples included by Cabbage. Tried signing the plugin using codesign (generic signing, do not have a developer account) but it made no difference.

When exporting as a standalone and navigating in the executable location the plugin works if invoked from the command line but it shows up as deactivated/incompatible on the GUI.

Writing as I do not know what to try next? Looked up the forum but did not come up with solution. Any suggestions? Is there something I am missing?

Thanks in advance!

Hi @mrn. Welcome to the forum. Best to try with one of the latest beta builds. There have been quite a few updates since 2.9.0, literally hundreds! Let me know if you have any better luck with the newer version.

Hi @rorywalsh!

Thanks getting back.
I tried with 2.9.227 and had the same problems to start with.

But after signing the .vst plugin folder, the .csd file in /Contents (this I had not tried before), and the plugin file in Contents/MacOS/, plugins were recognised and operational.

So I was not able to verify if it was all due to signing or using 2.9.0 or both but it is all functioning now!

Thanks for testing. You can try enabling adhoc signing in the Cabbage settings panel. It seems to work for some, and not for others. I find that Reaper is the one DAW I don’t have to codesign my plugins to test with.