Cabbage Logo
Back to Cabbage Site

Compiling Lore

yeah it seems to be working perfectly, just not diplaying the coloured bars

Hi @blip, I just tried the fork of Lore that @TartanLlama produced on my Mac and everything works as expected. Can you confirm that you are using the updated Lore code. Can you also confirm that the version of Cabbage you’re using is 2.8.154.

Hi, yes i’m also using the fork that @TartanLlama produced. The version of Cabbage is 2.8.155.

That’s strange. I’m running the same setup here. Can you confirm that the version you have has this on line 20 of /includes/EffectsManager.orc:

Sinstr9 = sprintfk("i %f 0 1 %i \"%s\"", 9+ifract, ieffectselect, SelectedEffect)

Yes this line is here also. My version of Csound is 6.18, and, as it was already installed (and working), i did not choose to install it again with Cabbage, maybe this could be the problem ?

No, that should be fine. I can’t think what might be causing the issues for you :thinking:

Using another os (macos 12) i managed to export a working AU, with the fx, graphics and everything. No luck with the VST and standalone versions, but that’s ok for me, as i just wanted to test Lore in an AU host.
Thanks for your help.

@TartanLlama sorry just jumping back in here now — was on the road all last week. stay tuned…

1 Like

I just found out about CSound, Cabbage, and Lore and decided to try to get Lore working and learn Cabbage while doing that.

I have lots of software dev experience in C, C++, Delphi, Java, and other stuff. Cabbage is super easy to install and seems quite a nice IDE. I checked out the latest Lore from github, the rev is dated today. The first time I tried to build I get this error at line 480, using Cabbage 2.8.0 on Windows 10, csound is
version 6.16

Csound output message console

UnifiedCSD:  C:\audiodev\puremagnetic\Lore\Lore Experimental Sound Console\Lore.csd
... snipped irrelevant content....
... build progress about 30 lines snipped...
error: syntax error, unexpected ')'  (token ")") from file C:\audiodev\puremagnetic\Lore\Lore Experimental Sound Console\Lore.csd (1)
 line 480:
>>>) <<<
Parsing failed due to invalid input!
Stopping on parser failure
cannot compile orchestra

The relevant code around line 480

kinitState delayk kinitState, 0.05
if kinitState < 1 then
    kHaveState = cabbageHasStateData()                <--- line 480
    kinitState = 1 

This seems to be a bug in the Cabbage IDE, as after several tries to build without any changes to the content of Lore.csd I was able to see LORE Version 1.0.27 open.

I am following the above thread and not sure what the WORKING version of LORE and CSOUND and CABBAGE is, if any known working combination exists.

I’m a windows C++ dev and I’ve got the cabbage repo build happening right now in visual studio 2022 and while I’m not an audio realtime guy I think I can figure out stuff.

Are we at the point of waiting for the Lore dev to update/merge fixes before his version is working on anything other than a no longer available superceded beta of Cabbage?

There were some changes made to Cabbage to help with this. You can grab a dev build from here:

No, it’s already done. Grab the latest beta version, and give it a twirl. Btw, the latest beta runs nativly on M1 Macs.

1 Like

That’s wonderful news that M1 native is in beta. I will help with beta testing, and as I am a total noob I think that will be helpful. I will surely find some sinkholes as that’s what I’m good at.

I have both mac and windows machines in active use in music and sound design and I think cabbage, csound, (and lore) are amazing.