Cabbage Logo
Back to Cabbage Site

Current Cabbage glitches in MultiTrack Studio

I have exported my new instrument and tried to load it to Multitrack Studio (v 10.5.1) to records some demo songs. Turns out it glitches in very specific way:

It should sound like this (as recorded in Traction Waveform):

It’s not pluggin specific, when I export some of my older plugins with current Cabbage it glitches in same way.

My older plugins (exported with Cabbage 2.3.0 or older) works fine in Multitrack Studio.

It does not glitches in other hosts which I tested it in - Bespoke Synth, Traction Waveform 12 or H. Seib VST host app.

I am not sure if this is bug with Cabbage or Multitrack Studio, but other plugins works in Multitrack Studio.

(Cabbage 2.9.0 on Windows 7)

I don’t have access to a Windows machine at the moment, but I can try on a Mac and see what happens. No one else has reported any issues with glitches, so it might be particular to Multitrack Studio. I probably won’t get a chance to look at this until the start of next week. When I do I will let you know.

1 Like

Btw, it’s always a good idea to try with the latest beta build first.

[edit] FWIW, Cabbage plugins don’t seem to work at with this DAW on Mac. I’m not sure what’s going on but it looks like the processing function is not even getting called…

I have found there is Cabbage 2.3.0 on my work computer. So I am able to backport my new plugins for Multitrack Studio until this bug is resolved.

This leads me to another two question:

  1. it’s possible to have multiple versions of Cabbage on one machine? (I tried to install 2.3.0 on my home machine, but it rewritted itself over 2.9.0 version)
  2. is there somewhere in the archives old enough version of Cabbage to run 32 bit edition of Windows XP? (I got an old netbook and I am transforming it into retro music station.)

If none of these is is possible it’s perfectly OK for me.

Yes, simply rename the Cabbage folder before installing the next version. Note that different versions of Cabbage are built with different versions of Csound, but they ‘should’ work with most versions.

Try here 32-bit builds for Windows (XP compatible)

I will take a look into the Multitrack Studio issue when I get a chance, it’s still on my todo list :slight_smile:

Following that WindowXP rabbit hole:

These builds works but I got audio dropouts. I tried to find optimal buffer size and it seems that bigger buffer size means less dropouts but they are still present. I also tried to optimize Windows itself (by following some old tutorials) but it didn’t make much difference.

It’s there anything I can do about optimise my CSD or Cabbage settings? For example - will lowering of sample rate (by setting sr in CSound) help?

(It’s old notebook so I am not expecting it to run new software smoothly, but maybe you know some additional trick…)

The simplest trick is to increase the ksmps size. Larger sizes should result in less dropouts, but it will increase the latency. Still worth a shot though :+1:

1 Like